Automatic dating machine all online india dating love

So, it should just give a list of explicitly installed packages (though this includes packages that were part of the default initial install) without all of the dependencies included due to these packages being installed.

To output the result into a text file: Well the question was for installed packages and this gives all installed packages minus the automatically installed dependencies.

It does include the initial packages as part of the initial install.

automatic dating machine-12

You can use Synaptic to save the current state of your installed packaged.

In Synaptic, select "file/save markings", Enter the name of the file to save the state to, and make sure to check the "Save full state, not only changes" box.

The file saved from this can be loaded into a new machine using "file/read markings" in Synaptic. Even though it is designed for servers, it can be also used from desktops as well.

Note that this won't keep track of which packages were explicitly installed by the user and which were installed as dependencies.

This means that if you use this method to recreate your setup on another machine, apt won't be able to remove unneeded dependencies when you remove a given package.

It's sad and amazing that @intuited 's comment is not better understood by the community.

Would the more "highly rated" contributors stop to think more before giving the advice that simply reloading old packages on a new ubuntu version is not a good idea(? With all the dpkg options I still do not see one that pulls out the 'expressely' installed packages by a user in order that THAT list can be reloaded and allowed to have its dependencies installed; I would love to know it - please share that info.

In the meantime, make a list of the packages you really need on a re-install and run that This should be the answer, but using aptitude is a bit unreliable because of Multiarch currently (fixes on the way), unfortunately.

Still +1 for pointing out only listing explicitly installed packages and a way to do this (despite it won't work on 11.10+ currently).

Tags: , ,